The source code and dockerfile for the GSW2024 AI Lab.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
This repo is archived. You can view files and clone it, but cannot push or open issues/pull-requests.
 
 
 
 
 
 

20 lines
454 B

{ stdenv, fetchFromGitHub, python3 }:
stdenv.mkDerivation rec {
name = "z3-${version}";
version = "4.6.0";
src = fetchFromGitHub {
owner = "Z3Prover";
repo = "z3";
rev = "z3-${version}";
sha256 = "1cgwlmjdbf4rsv2rriqi2sdpz9qxihxrcpm6a4s37ijy437xg78l";
};
buildInputs = [ python3 ];
phases = "unpackPhase buildPhase installPhase fixupPhase";
preBuild = ''
python3 scripts/mk_make.py --prefix=$out
cd build
'';
}