The source code and dockerfile for the GSW2024 AI Lab.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
This repo is archived. You can view files and clone it, but cannot push or open issues/pull-requests.
 
 
 
 
 
 

26 lines
723 B

{ stdenv, fetchFromGitHub }:
stdenv.mkDerivation rec {
name = "l3pp-${version}";
version = "git";
src = fetchFromGitHub {
owner = "hbruintjes";
repo = "l3pp";
rev = "e4f8d7fe6c328849aff34d2dfd6fd592c14070d5";
sha256 = "0bd0m4hj7iy5y9546sr7d156hmq6q7d5jys495jd26ngvibkv9hp";
};
phases = "unpackPhase installPhase fixupPhase";
installPhase = ''
mkdir -p $out/include $out/share/doc/l3pp
cp LICENSE Readme.md $out/share/doc/l3pp
cp -r *.h impl $out/include
'';
meta = with stdenv.lib; {
description = "Lightweight Logging Library for C++";
homepage = https://github.com/hbruintjes/l3pp;
maintainers = [ maintainers.spacefrogg ];
platforms = platforms.all;
};
}